Configuring a Router

Router Modes

Router> User mode
Router# Privileged mode
Router(config)# Global configuration mode
Router(config-if)# Interface mode
Router(config-subif)# Subinterface mode
Router(config-line)# Line mode
Router(config-router)# Router configuration mode

Global Configuration Mode

Router> Can see config, but not change
Router# Can see config and move to make changes
Router#config t Moves to global config mode
Router(config)# This prompt indicates that you can start making changes

Configuring a Router Name

Router(config)#hostname Cisco Name can be any word you choose

Configuring Passwords

Router(config)#enable password cisco Sets enable password
Router(config)#enable secret password class Sets enable secret password
Router(config)#line con 0
Router(config-line)#password console
Router(config-line)#login
Enters console-line mode
Sets console-line mode password to console
Router(config)#line vty 0 4
Router(config-line)#password telnet
Router(config-line)#login
Enters vty line mode for all 5 vty lines
Sets vty password to telnet
Enables password checking at login
Router(config)#line aux 0
Router(config-line)#password backdoor
Router(config-line)#login
Enters auxiliary line mode
Sets auxiliary line mode password to backdoor
Enables password checking at login

Password Encryption

Router(config)#service password-encryption Applies a weak encryption to passwords

Show Commands

Router#show ? Lists all show commands available
Router#show interfaces Displays statistics for all interfaces
Router#show interfaces serial 0 Displays statistics for a specific interface, in this case Serial 0
Router#show ip interface brief Displays a summary of all interfaces, including status and IP address assigned
Router#show controllers serial 0 Displays statistics for interface hardware. Statistics display if the clock rate is set and if the cable is DCE, DTE, or not attached
Router#show clock Displays time set on device
Router#show hosts Displays local host-to-IP address cache. These are the names and addresses of hosts on the network to which you can connect
Router#show users Displays all users connected to device
Router#show history Displays history of commands used
Router#show flash Displays info about Flash memory
Router#show version Displays info  about loaded software version
Router#show arp Displays the ARP table
Router#show protocols Displays status of configured Layer 3 protocols
Router#show startup-config Displays configuration saved in NVRAM
Router#show running-config Displays configuration currently running in RAM

Configuring a Serial Interface

Router(config)#int s0/0 Moves to interface Serial 0/0 mode
Router(config-if)#description Link to ISP Optional descriptor of the link is ocally significant
Router(config-if)#ip address 192.168.10.1 255.255.255.0 Assigns address and subnet mask to interface
Router(config-if)#clock rate 56000 Assigns a clock rate for the interface
Router(config-if)#no shut Turns interface on

TIP: The clock rate command is used only on a serial interface that has a DCE cable plugged into it. There must be a clock rate set on every serial link between routers. It does not matter which router has the DCE cable plugged into it, or which interface the cable is plugged into. Serial 0 on one router can be plugged into Serial 1 on another router.

Configuring an Ethernet/Fast Ethernet Interface

Router(config)#int fa0/0 Moves to Fast Ethernet 0/0 interface mode
Router(config-if)#description Accounting LAN Optional descriptor of the link is locally significant
Router(config-if)#ip address 192.168.20.1 255.255.255.0 Assigns address and subnet mask to interface
Router(config-if)#no shut Turns interface on

Creating a MOTD Banner

Router(config)#banner motd # This is a secure system. Authorized Personnel Only # # is known as a delimiting character. The delimiting character must surround the banner message and can be any character so long as it is not a character used within the body of the message

Assigning a Local Host Name to an IP Address

Router(config)#ip host london 172.16.1.3 Assigns a host name to the IP address. After this assignment, you can use the host name instead of an IP address when trying to Telnet or ping to that address

Setting the Clock Time Zone

Router(config)#clock timezone EST –5 Sets the time zone for display purposes. Based on coordinated universal time (Eastern Standard Time is 5 hours behind UTC)

no ip domain-lookup Command

Router(config)#no ip domain-lookup Turns off trying to automatically resolve an unrecognized command to a local host name

TIP: Ever type in a command incorrectly and left having to wait for a minute or two as the router tries to translate your command to a domain server of 255.255.255.255? The router is set by default to try to resolve any word that is not a command to a DNS server at address 255.255.255.255. If you are not going to set up DNS, turn this feature off to save you time as you type, especially if you are a poor typist.

logging synchronous Command

Router(config)#line con 0
Router(config-line)#logging synchronous
Turns on synchronous logging. Information items sent to console will not interrupt the command you are typing. The command will be moved to a new line

exec-timeout Command

Router(config)#line con 0
Router(config-line)#exec-timeout 0 0
Sets time limit when console automatically logs off. Set to 0 0 (minutes seconds) means console never logs off

Saving Configurations

Router(config)copy run start Saves the running-config to local NVRAM
Router(config)copy run tftp Saves the running-config remotely to TFTP server

Erasing Configurations

Router#erase start Deletes the startup-config file from NVRAM
Tags: What are two purposes for configuring a banner on a router? (Choose two ), What are two purposes for configuring a banner on a router?, what are two purposes for configuring a banner on a router, configuring a router

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>