SSH Configuration on Cisco Router in Packet Tracer – CCNA Lab

Topology Diagram

SSHConfigurationonCiscoRouterinPacketTracerCCNALab thumb SSH Configuration on Cisco Router in Packet Tracer – CCNA Lab

Task: Configure SSH on Router R2

Router 1

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#no shutdown 

Router 3

R3(config)#int fastEthernet 0/0

R3(config-if)#ip address 192.168.2.3 255.255.255.0

R3(config-if)#no shutdown

Router 2

R2(config)#int fastEthernet 0/0

R2(config-if)#ip address 192.168.1.2 255.255.255.0

R2(config-if)#no shutdown 

R2(config-if)#exit

R2(config)#int fastEthernet 0/1

R2(config-if)#ip address 192.168.2.2 255.255.255.0

R2(config-if)#no shutdown 

Step 1: Set router parameters

R2(config)#ip domain-name ccna5.com

Step 2: Generate Asymmetric Keys

R2(config)#crypto key generate rsa 

The name for the keys will be: R2.ccna5.com

Choose the size of the key modulus in the range of 360 to 2048 for your

  General Purpose Keys. Choosing a key modulus greater than 512 may take

  a few minutes.

 

How many bits in the modulus [512]: 

% Generating 512 bit RSA keys, keys will be non-exportable...[OK]

Step 3: Configure SSH timeouts and username

R2(config)#ip ssh time-out 15

R2(config)#ip ssh authentication-retries 2

R2(config)#username student password cisco

Step 4: Configure local authentication and vty

R2(config)#line vty 0 4

R2(config-line)#transport input ssh 

R2(config-line)#login local 

Verify SSH running

R1#ssh -l student 192.168.1.2

Open

Password: 

 

 

 

R2>

R3#ssh -l student 192.168.2.2

Open

Password: 

 

 

 

R2>

 

Download packet tracer file

Tags: yhs-fullyhosted_003, ccna lab, router packet tracer, ssh packet tracer, yhs-fh_lsonsw, Packet Tracer ROUTER, cisco packet tracer router, how to ssh in packet tracer 5 3, ssh packet tracer 5 3, how to configure ssh in Cisco packet tracer on multiple switches
  1. Lesego Medupe

    things are very interesting here,the topology itself and the configurations are so accurate,well and simpler explained!

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>